What’s Vulnerable › Vulnerabilities
CVE-2026-44338: PraisonAI ships and generates a legacy API server with authentication disabled by default, allowing unauthenticated workflow execution
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 32.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-08 · updated 2026-06-17
- Weakness: CWE-306
Description
PraisonAI is a multi-agent teams system. From version 2.5.6 to before version 4.6.34, PraisonAI ships a legacy Flask API server with authentication disabled by default. When that server is used, any caller that can reach it can access /agents and trigger the configured agents.yaml workflow through /chat without providing a token. This issue has been patched in version 4.6.34.
Affected products
- MervinPraison PraisonAI: from 2.5.6 before 4.6.34 — fixed in 4.6.34
How to fix
Upgrade to a fixed version: MervinPraison PraisonAI 4.6.34. Check the vendor advisory for mitigations.
References
- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-6rmh-7xcm-cpxj
- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-6rmh-7xcm-cpxj
Get alerted when CVE-2026-44338 or the next vulnerability affects your stack