What’s Vulnerable › Vulnerabilities
CVE-2026-44468: Incorrect Default Permissions in CODESYS Development System
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-26 · updated 2026-07-24
- Weakness: CWE-276
Description
The affected product creates a directory with insecure default permissions during administrative installation. This allows a low-privileged local attacker to modify a temporary file defining the components to be installed, enabling local privilege escalation by forcing the deployment of arbitrary components.
Affected products
- CODESYS Development System: before 3.5.22.20 — fixed in 3.5.22.20
How to fix
Upgrade to a fixed version: CODESYS Development System 3.5.22.20. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-44468 or the next vulnerability affects your stack