What’s Vulnerable › Vulnerabilities
CVE-2026-44469: Incorrect Default Permissions in CODESYS Development System
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-26 · updated 2026-07-24
- Weakness: CWE-276
Description
The affected product extracts installation files to a temporary directory with incorrect default permissions during administrative installation. A low-privileged local attacker can exploit a TOCTOU race condition with a practical time window to replace verified files with malicious ones before installation, resulting in local privilege escalation.
Affected products
- CODESYS Development System: before 3.5.22.20 — fixed in 3.5.22.20
How to fix
Upgrade to a fixed version: CODESYS Development System 3.5.22.20. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-44469 or the next vulnerability affects your stack