What’s Vulnerable › Vulnerabilities
CVE-2026-44477: CloudNativePG: Metrics exporter allows privilege escalation to PostgreSQL superuser and OS RCE
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-28 · updated 2026-07-15
- Weakness: CWE-250
Description
CloudNativePG is a platform designed to manage PostgreSQL databases within Kubernetes environments. Prior to 1.29.1 and 1.28.3, the CloudNativePG metrics exporter opens its PostgreSQL connection as the postgres superuser via the pod-local Unix socket, then demotes the session with SET ROLE pg_monitor. SET ROLE changes only current_user; session_user remains postgres. Any SQL expression evaluated inside the scrape session can invoke RESET ROLE to recover real superuser privileges, then use COPY ... TO PROGRAM to spawn an OS-level subprocess as the postgres user inside the primary pod. The READ ONLY transaction flag does not block this; it gates writes to database state, not external processes. This vulnerability is fixed in 1.29.1 and 1.28.3.
Affected products
- Linuxfoundation Cloudnativepg: before 1.28.3; from 1.29.0 before 1.29.1 — fixed in 1.28.3, 1.29.1
How to fix
Upgrade to a fixed version: Linuxfoundation Cloudnativepg 1.28.3, 1.29.1. Check the vendor advisory for mitigations.
References
- https://github.com/cloudnative-pg/cloudnative-pg/pull/10576
- https://github.com/cloudnative-pg/cloudnative-pg/security/advisories/GHSA-423p-g724-fr39
- https://access.redhat.com/security/cve/CVE-2026-44477
- https://bugzilla.redhat.com/show_bug.cgi?id=2482763
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-44477.json
Get alerted when CVE-2026-44477 or the next vulnerability affects your stack