What’s Vulnerable › Vulnerabilities
CVE-2026-44506: Medplum - Exposure of OAuth client secret via dynamic registration endpoint in self-hosted configurations
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-03 · updated 2026-09-09
- Weakness: CWE-200
Description
Medplum is a developer platform that enables development of healthcare apps. In Medplum versions 4.1.10 through 5.1.6, the /oauth2/register endpoint could return the client_secret of preconfigured OAuth clients defined via the defaultOAuthClients server configuration when a matching redirect_uri was provided. This issue has been patched in version 5.1.7.
Affected products
- medplum: from 4.1.10, < 5.1.7
References
- https://github.com/medplum/medplum/releases/tag/v5.1.7
- https://github.com/medplum/medplum/security/advisories/GHSA-ch8p-j6cm-r7w5
Get alerted when CVE-2026-44506 or the next vulnerability affects your stack