What’s Vulnerable › Vulnerabilities

CVE-2026-44573: Next.js: Middleware / Proxy bypass in Pages Router applications using i18n

Description

Next.js is a React framework for building full-stack web applications. From 12.2.0 to before 15.5.16 and 16.2.5, Applications using the Pages Router with i18n configured and middleware/proxy-based authorization can allow unauthorized access to protected page data through locale-less /_next/data/<buildId>/<page>.json requests. In affected configurations, middleware does not run for the unprefixed data route, allowing an attacker to retrieve SSR JSON for protected pages without passing the intended authorization checks. This vulnerability is fixed in 15.5.16 and 16.2.5.

Affected products

How to fix

Upgrade to a fixed version: Next.js 15.5.16, 16.2.5; Npm Next 15.5.16, 16.2.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-44573 or the next vulnerability affects your stack