What’s Vulnerable › Vulnerabilities
CVE-2026-44574: Next.js: Middleware / Proxy bypass through dynamic route parameter injection
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-13 · updated 2026-10-26
- Weakness: CWE-288
Description
Next.js is a React framework for building full-stack web applications. From 15.4.0 to before 15.5.16 and 16.2.5, applications that rely on middleware to protect dynamic routes can be vulnerable to authorization bypass. In affected deployments, specially crafted query parameters can alter the dynamic route value seen by the page while leaving the visible path unchanged, which can allow protected content to be rendered without passing the expected middleware check. This vulnerability is fixed in 15.5.16 and 16.2.5.
Affected products
- Next.js: from 15.4.0 before 15.5.16; from 16.0.0 before 16.2.5 — fixed in 15.5.16, 16.2.5
How to fix
Upgrade to a fixed version: Next.js 15.5.16, 16.2.5. Check the vendor advisory for mitigations.
References
- https://github.com/vercel/next.js/security/advisories/GHSA-492v-c6pp-mqqv
- https://access.redhat.com/errata/RHSA-2026:34608
- https://access.redhat.com/errata/RHSA-2026:37272
- https://access.redhat.com/errata/RHSA-2026:40974
- https://access.redhat.com/errata/RHSA-2026:54435
- https://access.redhat.com/security/cve/CVE-2026-44574
- https://bugzilla.redhat.com/show_bug.cgi?id=2477207
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-44574.json
Get alerted when CVE-2026-44574 or the next vulnerability affects your stack