What’s Vulnerable › Vulnerabilities
CVE-2026-44577: Next.js: Denial of Service in the Image Optimization API
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-13 · updated 2026-10-26
- Weakness: CWE-770
Description
Next.js is a React framework for building full-stack web applications. From 10.0.0 to before 15.5.16 and 16.2.5, when self-hosting Next.js with the default image loader, the Image Optimization API fetches local images entirely into memory without enforcing a maximum size limit. An attacker could cause out-of-memory conditions by requesting large local assets from the /_next/image endpoint that match the images.localPatterns configuration (by default, all patterns are allowed). This vulnerability is fixed in 15.5.16 and 16.2.5.
Affected products
- Next.js: from 10.0.0 before 15.5.16; from 16.0.0 before 16.2.5 — fixed in 15.5.16, 16.2.5
- Npm Next: from 10.0.0 before 15.5.16; from 16.0.0 before 16.2.5 — fixed in 15.5.16, 16.2.5
How to fix
Upgrade to a fixed version: Next.js 15.5.16, 16.2.5; Npm Next 15.5.16, 16.2.5. Check the vendor advisory for mitigations.
References
- https://github.com/vercel/next.js/security/advisories/GHSA-h64f-5h5j-jqjh
- https://access.redhat.com/errata/RHSA-2026:34608
- https://access.redhat.com/errata/RHSA-2026:37272
- https://access.redhat.com/errata/RHSA-2026:40974
- https://access.redhat.com/errata/RHSA-2026:54435
- https://access.redhat.com/security/cve/CVE-2026-44577
- https://bugzilla.redhat.com/show_bug.cgi?id=2477194
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-44577.json
Get alerted when CVE-2026-44577 or the next vulnerability affects your stack