What’s Vulnerable › Vulnerabilities
CVE-2026-44578: Next.js: Server-side request forgery in applications using WebSocket upgrades
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 35.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-13 · updated 2026-10-26
- Weakness: CWE-918
Description
Next.js is a React framework for building full-stack web applications. From 13.4.13 to before 15.5.16 and 16.2.5, self-hosted applications using the built-in Node.js server can be vulnerable to server-side request forgery through crafted WebSocket upgrade requests. An attacker can cause the server to proxy requests to arbitrary internal or external destinations, which may expose internal services or cloud metadata endpoints. Vercel-hosted deployments are not affected. This vulnerability is fixed in 15.5.16 and 16.2.5.
Affected products
- Next.js: from 13.4.13 before 15.5.16; from 16.0.0 before 16.2.5 — fixed in 15.5.16, 16.2.5
How to fix
Upgrade to a fixed version: Next.js 15.5.16, 16.2.5. Check the vendor advisory for mitigations.
References
- https://github.com/vercel/next.js/security/advisories/GHSA-c4j6-fc7j-m34r
- https://access.redhat.com/errata/RHSA-2026:34608
- https://access.redhat.com/errata/RHSA-2026:37272
- https://access.redhat.com/errata/RHSA-2026:40974
- https://access.redhat.com/errata/RHSA-2026:54435
- https://access.redhat.com/security/cve/CVE-2026-44578
- https://bugzilla.redhat.com/show_bug.cgi?id=2477187
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-44578.json
Get alerted when CVE-2026-44578 or the next vulnerability affects your stack