What’s Vulnerable › Vulnerabilities
CVE-2026-44579: Next.js: Denial of Service via connection exhaustion in applications using Cache Components
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-13 · updated 2026-10-26
- Weakness: CWE-770
Description
Next.js is a React framework for building full-stack web applications. From to before 15.5.16 and 16.2.5, applications using Partial Prerendering through the Cache Components feature can be vulnerable to connection exhaustion through crafted POST requests to a server action. In affected configurations, a malicious request can trigger a request-body handling deadlock that leaves connections open for an extended period, consuming file descriptors and server capacity until legitimate users are denied service. This vulnerability is fixed in 15.5.16 and 16.2.5.
Affected products
- Next.js: from 15.0.0 before 15.5.16; from 16.0.0 before 16.2.5 — fixed in 15.5.16, 16.2.5
How to fix
Upgrade to a fixed version: Next.js 15.5.16, 16.2.5. Check the vendor advisory for mitigations.
References
- https://github.com/vercel/next.js/security/advisories/GHSA-mg66-mrh9-m8jx
- https://access.redhat.com/errata/RHSA-2026:34608
- https://access.redhat.com/errata/RHSA-2026:37272
- https://access.redhat.com/errata/RHSA-2026:40974
- https://access.redhat.com/errata/RHSA-2026:54435
- https://access.redhat.com/security/cve/CVE-2026-44579
- https://bugzilla.redhat.com/show_bug.cgi?id=2477193
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-44579.json
Get alerted when CVE-2026-44579 or the next vulnerability affects your stack