What’s Vulnerable › Vulnerabilities

CVE-2026-44580: Next.js: Cross-site scripting in beforeInteractive scripts with untrusted input

Description

Next.js is a React framework for building full-stack web applications. From 13.0.0 to before 15.5.16 and 16.2.5, applications that use beforeInteractive scripts together with untrusted content can be vulnerable to cross-site scripting. In affected versions, serialized script content was not escaped safely before being embedded into the document, which could allow attacker-controlled input to break out of the intended script context and execute arbitrary JavaScript in a visitor's browser. This vulnerability is fixed in 15.5.16 and 16.2.5.

Affected products

How to fix

Upgrade to a fixed version: Next.js 15.5.16, 16.2.5; Npm Next 15.5.16, 16.2.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-44580 or the next vulnerability affects your stack