What’s Vulnerable › Vulnerabilities
CVE-2026-44581: Next.js: Cross-site scripting in App Router applications using CSP nonces
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-13 · updated 2026-10-26
- Weakness: CWE-79
Description
Next.js is a React framework for building full-stack web applications. From 13.4.0 to before 15.5.16 and 16.2.5, App Router applications that rely on CSP nonces can be vulnerable to stored cross-site scripting when deployed behind shared caches. In affected versions, malformed nonce values derived from request headers could be reflected into rendered HTML in an unsafe way, allowing an attacker to poison cached responses and cause script execution for later visitors. This vulnerability is fixed in 15.5.16 and 16.2.5.
Affected products
- Next.js: from 13.4.0 before 15.5.16; from 16.0.0 before 16.2.5 — fixed in 15.5.16, 16.2.5
- Npm Next: from 13.4.0 before 15.5.16; from 16.0.0 before 16.2.5 — fixed in 15.5.16, 16.2.5
How to fix
Upgrade to a fixed version: Next.js 15.5.16, 16.2.5; Npm Next 15.5.16, 16.2.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-44581 or the next vulnerability affects your stack