What’s Vulnerable › Vulnerabilities
CVE-2026-44582: Next.js: Cache poisoning via collisions in React Server Component cache-busting
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-13 · updated 2026-10-26
- Weakness: CWE-328
Description
Next.js is a React framework for building full-stack web applications. From 13.4.6 to before 15.5.16 and 16.2.5, React Server Component responses can be vulnerable to cache poisoning in deployments that rely on shared caches with insufficient response partitioning. In affected conditions, collisions in the _rsc cache-busting value can allow an attacker to poison cache entries so users receive the wrong response variant for a given URL. This vulnerability is fixed in 15.5.16 and 16.2.5.
Affected products
- Next.js: from 13.4.6 before 15.5.16; from 16.0.0 before 16.2.5 — fixed in 15.5.16, 16.2.5
How to fix
Upgrade to a fixed version: Next.js 15.5.16, 16.2.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-44582 or the next vulnerability affects your stack