What’s Vulnerable › Vulnerabilities
CVE-2026-44595: Yamcs: Unauthorized user enumeration via IAM API endpoints
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-16 · updated 2026-07-18
- Weakness: CWE-862
Description
Yamcs is a mission control framework. Prior to 5.12.7, the IAM API endpoints listUsers, getUser, listGroups, and getGroup in yamcs-core did not enforce the required SystemPrivilege.ControlAccess check in yamcs-core/src/main/java/org/yamcs/http/api/IamApi.java, so any authenticated user, even one with low or no privileges, could enumerate all user accounts in the system including their usernames, superuser status, and group memberships. This issue is fixed in versions 5.12.7 and 5.13.0.
Affected products
- yamcs: before 5.12.7 — fixed in 5.12.7
How to fix
Upgrade to a fixed version: yamcs 5.12.7. Check the vendor advisory for mitigations.
References
- https://github.com/yamcs/yamcs/commit/0e12b518f103f24681299318a30a460fe4327b88
- https://github.com/yamcs/yamcs/commit/e90099fba98e96214217c195b6a5b87b5f46e51c
- https://github.com/yamcs/yamcs/releases/tag/yamcs-5.12.7
- https://github.com/yamcs/yamcs/releases/tag/yamcs-5.13.0
- https://github.com/yamcs/yamcs/security/advisories/GHSA-p2rj-mrmc-9w29
- https://github.com/yamcs/yamcs/security/advisories/GHSA-p2rj-mrmc-9w29
Get alerted when CVE-2026-44595 or the next vulnerability affects your stack