What’s Vulnerable › Vulnerabilities
CVE-2026-44613: Apache Zeppelin: Cross-site request forgery in REST and WebSocket request handling
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-30 · updated 2026-10-23
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in Apache Zeppelin. The default CORS configuration allowed cross-origin state-changing requests and accepted text/plain request bodies, allowing an attacker who lures an authenticated user to a malicious site to perform actions on the user's behalf through REST and WebSocket endpoints. This issue affects Apache Zeppelin versions 0.6.0 through 0.12.0. Users are recommended to upgrade to version 0.12.1, which fixes this issue.
Affected products
- Apache Software Foundation Apache Zeppelin: from 0.6.0 before 0.12.1 — fixed in 0.12.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Zeppelin 0.12.1. Check the vendor advisory for mitigations.
References
- https://github.com/apache/zeppelin/pull/5229
- https://lists.apache.org/thread/94trzcny14c1csgotsnkyrfsflt30b2c
- http://www.openwall.com/lists/oss-security/2026/07/30/1
- https://www.ox.security/blog/cve-2026-44613-turning-a-csrf-into-silent-unauthorized-actions/
Get alerted when CVE-2026-44613 or the next vulnerability affects your stack