What’s Vulnerable › Vulnerabilities

CVE-2026-44631: Apache HTTP Server: Heap Underflow in `ap_regname` via Signed Char Overflow

Description

Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache HTTP Server 2.4.68. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-44631 or the next vulnerability affects your stack