What’s Vulnerable › Vulnerabilities
CVE-2026-44634: Stack buffer overflows in SimpleBLE
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-10 · updated 2026-07-23
- Weakness: CWE-121
Description
SimpleBLE is a cross-platform library and bindings for Bluetooth Low Energy (BLE). Prior to version 0.14.0, there are multiple stack-based buffer overflow vulnerabilities in SimpleBLE. There is a stack overflow vulnerability in the dongl backend’s Protocol::simpleble_write function (local, caller-controlled input). A stack overflow vulnerability when processing manufacturer-specific data in BLE advertisements (remote, no pairing or connection required). Lastly, a stack overflow vulnerability when processing service data in BLE advertisements (remote, no pairing or connection required). This issue has been patched in version 0.14.0.
Affected products
- simpleble: before 0.14.0
References
- https://github.com/simpleble/simpleble/commit/1501d59d76a4280268372afb1b157bf6caeacba6
- https://github.com/simpleble/simpleble/pull/466
- https://github.com/simpleble/simpleble/releases/tag/v0.14.0
- https://github.com/simpleble/simpleble/security/advisories/GHSA-8h89-q8m2-c8fp
Get alerted when CVE-2026-44634 or the next vulnerability affects your stack