What’s Vulnerable › Vulnerabilities
CVE-2026-44636: libsixel: integer overflow in encoder
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-14 · updated 2026-10-26
- Weakness: CWE-122
Description
libsixel is a SIXEL encoder/decoder implementation derived from kmiya's sixel. From to 1.8.7-r1, signed integer overflow in sixel_encode_highcolor's allocation size calculation can lead to a heap buffer overflow. The public sixel_encode entry point validates only that width and height are greater than zero, with no upper bound. width and height are multiplied as plain int when computing the allocation size for paletted_pixels and normalized_pixels. Any caller that asks libsixel to encode a pixel buffer with width times height greater than INT_MAX (about 2.15 billion) will hit a wrapped allocation size; under the right wrap, the malloc succeeds with a buffer much smaller than the encoder expects, and the encoder writes past the end of the heap allocation. This vulnerability is fixed in 1.8.7-r2.
Affected products
- saitoha libsixel: from 1.4.4 before 1.8.7-r2 — fixed in 1.8.7-r2
How to fix
Upgrade to a fixed version: saitoha libsixel 1.8.7-r2. Check the vendor advisory for mitigations.
References
- https://github.com/saitoha/libsixel/security/advisories/GHSA-hx93-w8p2-ffh5
- https://github.com/saitoha/libsixel/security/advisories/GHSA-hx93-w8p2-ffh5
Get alerted when CVE-2026-44636 or the next vulnerability affects your stack