What’s Vulnerable › Vulnerabilities
CVE-2026-44643: Angular Expressions - Remote Code Execution using filters
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-11 · updated 2026-10-26
- Weakness: CWE-95
Description
Angular Expressions provides expressions for the Angular.JS web framework as a standalone module. Prior to 1.5.2, an attacker can write a malicious expression using filters that escapes the sandbox to execute arbitrary code on the system. This vulnerability is fixed in 1.5.2.
Affected products
- peerigon angular-expressions: before 1.5.2 — fixed in 1.5.2
How to fix
Upgrade to a fixed version: peerigon angular-expressions 1.5.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-44643 or the next vulnerability affects your stack