What’s Vulnerable › Vulnerabilities
CVE-2026-44709: pam_usb: PINENTRY_FALLBACK_APP environment variable allows arbitrary command execution
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-27 · updated 2026-10-25
- Weakness: CWE-78
Description
pam_usb provides hardware authentication for Linux using ordinary removable media. Prior to 0.8.7, pamusb-pinentry reads the PINENTRY_FALLBACK_APP environment variable and executes it directly without any validation. Any process that can set environment variables before pamusb-pinentry is invoked can point PINENTRY_FALLBACK_APP at an arbitrary binary or script and have it executed with the privileges of the pam_usb tool chain. This vulnerability is fixed in 0.8.7.
Affected products
- mcdope pam_usb: before 0.8.7
References
- https://github.com/mcdope/pam_usb/security/advisories/GHSA-jxrj-q67x-wr4c
- https://github.com/mcdope/pam_usb/security/advisories/GHSA-jxrj-q67x-wr4c
Get alerted when CVE-2026-44709 or the next vulnerability affects your stack