What’s Vulnerable › Vulnerabilities
CVE-2026-44713: pam_usb: Command injection via $TMUX environment variable leads to RCE as root
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-27 · updated 2026-10-26
- Weakness: CWE-78
Description
pam_usb provides hardware authentication for Linux using ordinary removable media. Prior to 0.8.7, src/tmux.c reads the user's $TMUX environment variable, splits it on commas, and interpolates the socket-path component directly into a shell command passed to popen(). Because the value is placed inside double-quotes without sanitisation, any value containing " terminates the quoted string and injects arbitrary shell syntax. popen() runs as root inside the PAM stack. This vulnerability is fixed in 0.8.7.
Affected products
- mcdope pam_usb: before 0.8.7
References
Get alerted when CVE-2026-44713 or the next vulnerability affects your stack