What’s Vulnerable › Vulnerabilities
CVE-2026-44728: Improper Control of Generation of Code when compiling specifically crafted malicious code with @babel/plugin-transform-modules-systemjs
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-26 · updated 2026-07-24
- Weakness: CWE-94
Description
Babel is a compiler for writing next generation JavaScript. From 7.12.0 to before 7.29.4 and 8.0.0-alpha.13, using Babel to compile code that was specifically crafted by an attacker can cause Babel to generate output code that executes arbitrary code. This vulnerability is fixed in 7.29.4 and 8.0.0-alpha.13.
Affected products
- babel: from 7.12.0 before 7.29.4; 8.0.0-alpha0, 8.0.0-alpha1, 8.0.0-alpha10, 8.0.0-alpha11, 8.0.0-alpha12, 8.0.0-alpha2 (+7) — fixed in 7.29.4
How to fix
Upgrade to a fixed version: babel 7.29.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-44728 or the next vulnerability affects your stack