What’s Vulnerable › Vulnerabilities
CVE-2026-44737: grav-plugin-admin: Stored Cross-Site Scripting (XSS) Reflected endpoint /admin/pages/[page], parameter data[header][title]
- Severity: medium (CVSS 6.2 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-11 · updated 2026-10-26
- Weakness: CWE-79
Description
grav-plugin-admin is the admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.10.49.5, the application fails to properly validate and sanitize user input in the data[header][title] parameter. As a result, attackers can craft a malicious URL with an XSS payload. When this URL is accessed, the injected script is reflected back in the HTTP response and executed within the context of the victim's browser session. This vulnerability is fixed in 1.10.49.5.
Affected products
- getgrav grav-plugin-admin: before 1.10.49.5
References
- https://github.com/getgrav/grav-plugin-admin/commit/f67cc18e81d8767bb43d29ee6422c55ed0427803
- https://github.com/getgrav/grav/security/advisories/GHSA-fmg2-f5r9-24qc
- https://github.com/getgrav/grav/security/advisories/GHSA-fmg2-f5r9-24qc
Get alerted when CVE-2026-44737 or the next vulnerability affects your stack