What’s Vulnerable › Vulnerabilities
CVE-2026-44783: Discourse: Replying to a whisper lets non-whisperers create staff-only whisper posts
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-12 · updated 2026-06-17
- Weakness: CWE-284
Description
Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.4, 2026.3.0-latest to before 2026.3.1, and 2026.4.0-latest to before 2026.4.1, a flaw in how replies to whisper posts are handled allows authenticated users outside the groups configured in whispers_allowed_groups to post into a topic's staff-only whisper channel. The injected content is visible to whisperers (typically staff) alongside legitimate whispers. Only sites that have whispers enabled are affected. This issue has been patched in versions 2026.1.4, 2026.3.1, 2026.4.1, and 2026.5.0-latest.1.
Affected products
- discourse: before 2026.1.0; from 2026.1.0 before 2026.1.4; from 2026.3.0 before 2026.3.1; from 2026.4.0 before 2026.4.1; 2026.5.0 — fixed in 2026.1.0, 2026.1.4, 2026.3.1, 2026.4.1
How to fix
Upgrade to a fixed version: discourse 2026.1.0, 2026.1.4, 2026.3.1, 2026.4.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-44783 or the next vulnerability affects your stack