What’s Vulnerable › Vulnerabilities
CVE-2026-44795: Spinnaker: Non-safe yaml deserialization allowing RCE when using specific types
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-10 · updated 2026-07-21
- Weakness: CWE-470
Description
Spinnaker is an open source, multi-cloud continuous delivery platform. Prior to 2026.1.0, 2026.0.3, 2025.4.4, and 2025.3.3, unsafe YAML processing bypasses safe deserialization when using CloudFormation deployments or CloudFoundry baking. The use of a non-safe constructor allows arbitrary loading of Java classes, leading to remote code execution. This issue is fixed in versions 2026.1.0, 2026.0.3, 2025.4.4, and 2025.3.3.
Affected products
- spinnaker: before 2025.3.3; from 2025.4.0 before 2025.4.4; from 2026.0.0 before 2026.0.3 — fixed in 2025.3.3, 2025.4.4, 2026.0.3
How to fix
Upgrade to a fixed version: spinnaker 2025.3.3, 2025.4.4, 2026.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/spinnaker/spinnaker/commit/4cbe1d5fea9df573aadfd8b093fb4b594b354ee5
- https://github.com/spinnaker/spinnaker/commit/e57c0db4584b398473a7bbb19402ce6c1e89b627
- https://github.com/spinnaker/spinnaker/commit/f69d7b534d068ed74d0d3a1fbf17e2c945d36e5e
- https://github.com/spinnaker/spinnaker/security/advisories/GHSA-c8q4-9h32-2ww8
Get alerted when CVE-2026-44795 or the next vulnerability affects your stack