What’s Vulnerable › Vulnerabilities
CVE-2026-4480: Samba: samba: remote code execution in printing subsystem via unescaped job description
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 13.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-26 · updated 2026-09-01
- Weakness: CWE-78
Description
A flaw was found in the Samba printing subsystem. Samba passes the client-controlled job description string to the command configured with the "print command" setting via the "%J" substitution character without escaping shell meta characters. A remote attacker could exploit this vulnerability by sending a specially crafted print job description that contains unescaped shell characters. This could lead to remote code execution on the affected system.
Affected products
- Red Hat Enterprise Linux: 7.0, 8.0, 9.0, 10.0
- Red Hat OpenShift Container Platform 4.18: 4.0
- Samba: from 4.1.0 before 4.2.1 — fixed in 4.2.1
How to fix
Upgrade to a fixed version: Samba 4.2.1. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2026:22644
- https://access.redhat.com/errata/RHSA-2026:22963
- https://access.redhat.com/errata/RHSA-2026:25049
- https://access.redhat.com/errata/RHSA-2026:25979
- https://access.redhat.com/errata/RHSA-2026:28053
- https://access.redhat.com/errata/RHSA-2026:28054
- https://access.redhat.com/errata/RHSA-2026:28055
- https://access.redhat.com/errata/RHSA-2026:28056
- https://access.redhat.com/errata/RHSA-2026:28057
- https://access.redhat.com/errata/RHSA-2026:28058
- https://access.redhat.com/errata/RHSA-2026:28132
- https://access.redhat.com/security/cve/CVE-2026-4480
Get alerted when CVE-2026-4480 or the next vulnerability affects your stack