What’s Vulnerable › Vulnerabilities
CVE-2026-44838: RabbitMQ MQTT Topic Permission Authorization Bypass
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-27 · updated 2026-10-26
- Weakness: CWE-863
Description
RabbitMQ is a messaging and streaming broker. From 4.2.0 to before 4.2.4, RabbitMQ's MQTT plugin allows for topic-level authorization using regular expressions with variable substitution. Administrators can create patterns such as ^{client_id}-sensors$ to restrict user access to topics that include their client ID. However, the client_id is provided by the user in the MQTT CONNECT packet and is inserted into the regex pattern without escaping special regex characters. This flaw enables an authenticated MQTT user to inject regex operators to bypass authorization. This vulnerability is fixed in 4.2.4 and 4.3.0.
Affected products
- rabbitmq-server: from 4.2.0 before 4.2.4 — fixed in 4.2.4
How to fix
Upgrade to a fixed version: rabbitmq-server 4.2.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-44838 or the next vulnerability affects your stack