What’s Vulnerable › Vulnerabilities

CVE-2026-44849: Portainer: Endpoint security bypass via Swarm service create/update

Description

Portainer Community Edition is a lightweight service delivery platform for containerized applications that can be used to manage Docker, Swarm, Kubernetes and ACI environments. From 2.33.0 to before 2.33.8, 2.39.2, and 2.41.0, Portainer enforces seven EndpointSecuritySettings restrictions that administrators configure to restrict the container configurations non-admin users can launch: privileged mode, host PID namespace, device mapping, capabilities, sysctls, security-opt (Seccomp / AppArmor), and bind mounts. These restrictions are enforced on the standard container creation path, but several of them are not applied on the Docker Swarm service API. This vulnerability is fixed in 2.33.8, 2.39.2, and 2.41.0.

Affected products

How to fix

Upgrade to a fixed version: portainer 2.33.8, 2.39.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-44849 or the next vulnerability affects your stack