What’s Vulnerable › Vulnerabilities
CVE-2026-44856: Authenticated Stack-Based Buffer Overflow in PAPI Services
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-12 · updated 2026-10-26
- Weakness: CWE-121
Description
Stack-based buffer overflow vulnerabilities exist in several underlying management service components accessed through the command-line interface of the AOS-8 and AOS-10 Operating Systems. An authenticated attacker with administrative privileges could exploit these vulnerabilities by sending specially crafted requests to the affected services. Successful exploitation could allow the attacker to execute arbitrary code with elevated privileges on the underlying operating system.
Affected products
- Hewlett Packard Enterprise (HPE) ArubaOS (AOS): from 6.5.4.0 before 8.10.0.22; from 8.11.0.0 before 8.12.0.7; from 8.13.0.0 before 8.13.1.2; from 10.4.0.0 before 10.4.1.11; from 10.5.0.0 before 10.7.2.3 — fixed in 8.10.0.22, 8.12.0.7, 8.13.1.2, 10.4.1.11, 10.7.2.3
- Arubanetworks Sd-Wan: from 8.6.0.4-2.2.0.0 through 8.6.0.4-2.2.0.7; from 8.7.0.0-2.3.0.0 through 8.7.0.0-2.3.0.9
How to fix
Upgrade to a fixed version: Hewlett Packard Enterprise (HPE) ArubaOS (AOS) 8.10.0.22, 8.12.0.7, 8.13.1.2, 10.4.1.11. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-44856 or the next vulnerability affects your stack