What’s Vulnerable › Vulnerabilities
CVE-2026-44891: Netty: Denial of Service via Unbounded Headers in StompSubframeDecoder
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-17 · updated 2026-07-23
- Weakness: CWE-400
Description
Netty is a network application framework for development of protocol servers and clients. Prior to 4.1.136.Final and 4.2.16.Final, io.netty.handler.codec.stomp.StompSubframeDecoder fails to limit the total number of headers or their cumulative size per frame, and the maxLineLength parameter only restricts individual header lines. An attacker can send a large number of short headers that are accumulated in memory inside DefaultStompHeadersSubframe until the JVM throws an OutOfMemoryError, causing denial of service for servers exposing a STOMP endpoint based on StompSubframeDecoder. This issue is fixed in versions 4.1.136.Final and 4.2.16.Final.
Affected products
- netty: before 4.1.136; from 4.2.0 before 4.2.16 — fixed in 4.1.136, 4.2.16
How to fix
Upgrade to a fixed version: netty 4.1.136, 4.2.16. Check the vendor advisory for mitigations.
References
- https://github.com/netty/netty/commit/5b68c61f37aa4a3045cba624cbea239655c9003b
- https://github.com/netty/netty/commit/bb2ff68a1fb71cb4b0eb9a9e17b66c52aff680c6
- https://github.com/netty/netty/pull/17063
- https://github.com/netty/netty/pull/17065
- https://github.com/netty/netty/releases/tag/netty-4.1.136.Final
- https://github.com/netty/netty/releases/tag/netty-4.2.16.Final
- https://github.com/netty/netty/security/advisories/GHSA-vhch-2wf3-m8rp
- https://github.com/netty/netty/security/advisories/GHSA-vhch-2wf3-m8rp
Get alerted when CVE-2026-44891 or the next vulnerability affects your stack