What’s Vulnerable › Vulnerabilities
CVE-2026-44902: opentelemetry-js: Prometheus exporter process crash via malformed HTTP request
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-27 · updated 2026-08-27
- Weakness: CWE-755
Description
opentelemetry-js is the OpenTelemetry JavaScript Client. Prior to 0.217.0, a single malformed HTTP request crashes any Node.js process running the OpenTelemetry JS Prometheus exporter. The metrics endpoint (default 0.0.0.0:9464) has no error handling around URL parsing, so a request with an invalid URI causes an uncaught TypeError that terminates the process. This vulnerability is fixed in 0.217.0.
Affected products
- @opentelemetry Opentelemetry/Auto-Instrumentations-Node: before 0.75.0 — fixed in 0.75.0
- @opentelemetry Opentelemetry/Exporter-Prometheus: before 0.217.0 — fixed in 0.217.0
- @opentelemetry Opentelemetry/Sdk-Node: before 0.217.0 — fixed in 0.217.0
How to fix
Upgrade to a fixed version: @opentelemetry Opentelemetry/Auto-Instrumentations-Node 0.75.0; @opentelemetry Opentelemetry/Exporter-Prometheus 0.217.0; @opentelemetry Opentelemetry/Sdk-Node 0.217.0. Check the vendor advisory for mitigations.
References
- https://github.com/open-telemetry/opentelemetry-js/security/advisories/GHSA-q7rr-3cgh-j5r3
- https://github.com/open-telemetry/opentelemetry-js/security/advisories/GHSA-q7rr-3cgh-j5r3
Get alerted when CVE-2026-44902 or the next vulnerability affects your stack