What’s Vulnerable › Vulnerabilities

CVE-2026-44911: Apache NiFi: Incorrect Authorization for Configuration Verification Requests

Description

Authorization handling for component configuration verification requests in Apache NiFi 1.15.0 through 2.9.0 allows clients with read access to submit proposed configuration properties. The proposed properties override current configuration, enabling users with read access to invoke predefined verification methods with alternative settings. Apache NiFi installations that do not implement different levels of authorization for viewing and modifying component configuration are not subject to this vulnerability. Upgrading to Apache NiFi 2.10.0 is the recommended mitigation, requiring write access to submit configuration verification requests.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache NiFi 2.10.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-44911 or the next vulnerability affects your stack