What’s Vulnerable › Vulnerabilities
CVE-2026-44914: Apache NiFi: Missing Authorization of Restricted Permissions when Replacing Flow Contents
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-22 · updated 2026-10-25
- Weakness: CWE-862
Description
Apache NiFi 1.12.0 through 2.9.0 are missing authorization when replacing Process Groups that include extension components with specific Required Permissions based on the Restricted annotation. The Restricted annotation indicates additional privileges required, but framework authorization did not check restricted status when handling requests to replace Process Groups. The missing authorization permits a user with general write access to add components with Restricted status. Apache NiFi installations that do not implement specific authorization for Restricted components are not subject to this vulnerability because the framework enforces write permissions as the security boundary. Upgrading to Apache NiFi 2.9.0 is the recommended mitigation, which removes the implementation of Restricted status authorization from the framework.
Affected products
- Apache Software Foundation Apache NiFi: from 1.12.0 before 2.10.0 — fixed in 2.10.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache NiFi 2.10.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/ydr34t03xd1n0t9oogpzogjrd5y93838
- http://www.openwall.com/lists/oss-security/2026/06/20/6
Get alerted when CVE-2026-44914 or the next vulnerability affects your stack