What’s Vulnerable › Vulnerabilities
CVE-2026-44915: Apache APISIX: Cas-auth plugin open redirect via unsanitized cookie value
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-19 · updated 2026-10-26
- Weakness: CWE-601
Description
URL Redirection to Untrusted Site ('Open Redirect') vulnerability in Apache APISIX. The default configuration of cas-auth in Apache APISIX is vulnerable to phishing and credential theft. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache APISIX: from 3.0.0 before 3.17.0 — fixed in 3.17.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache APISIX 3.17.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/2syk2kkzjnpzrdh98plbzj8os7wn521c
- http://www.openwall.com/lists/oss-security/2026/06/19/8
Get alerted when CVE-2026-44915 or the next vulnerability affects your stack