What’s Vulnerable › Vulnerabilities

CVE-2026-44916

Description

In OpenStack Ironic before 35.0.2 (in a certain non-default configuration), instance_info['ks_template'] is rendered without sandboxing.

Affected products

How to fix

Upgrade to a fixed version: OpenStack Ironic 26.1.7, 29.0.6, 32.0.2, 35.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-44916 or the next vulnerability affects your stack