What’s Vulnerable › Vulnerabilities

CVE-2026-44917

Description

OpenStack Ironic before 35.0.2 allows a malicious authenticated project admin or manager to read local files on the Ironic conductor via a pxe_template.

Affected products

How to fix

Upgrade to a fixed version: OpenStack Ironic 26.1.7, 29.0.6, 32.0.2, 35.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-44917 or the next vulnerability affects your stack