What’s Vulnerable › Vulnerabilities
CVE-2026-44927
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-08 · updated 2026-06-17
- Weakness: CWE-197
Description
In uriparser before 1.0.2, there is pointer difference truncation to int in various places.
Affected products
- uriparser: before 1.0.2 — fixed in 1.0.2
How to fix
Upgrade to a fixed version: uriparser 1.0.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-44927 or the next vulnerability affects your stack