What’s Vulnerable › Vulnerabilities
CVE-2026-44930: Apache CXF: LDAP Injection vulnerability in XKMS LDAP Repository
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-22 · updated 2026-07-23
- Weakness: CWE-90
Description
An LDAP injection vulnerability in the LDAP Certificate repository of the XKMS server in Apache CXF may allow an attacker to retrieve arbitrary certificates from the repository. Users are recommended to upgrade to versions 4.2.1, 4.1.6 or 3.6.11, which fix this issue.
Affected products
- Apache Software Foundation Apache CXF: before 3.6.11; from 4.0.0 before 4.1.6; 4.2.0 — fixed in 3.6.11, 4.1.6
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache CXF 3.6.11, 4.1.6. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/c1zqxppo1m5z3kbdhjn5p991zk09ynkh
- http://www.openwall.com/lists/oss-security/2026/05/22/9
- https://access.redhat.com/errata/RHSA-2026:37390
- https://access.redhat.com/security/cve/CVE-2026-44930
- https://bugzilla.redhat.com/show_bug.cgi?id=2480728
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-44930.json
Get alerted when CVE-2026-44930 or the next vulnerability affects your stack