What’s Vulnerable › Vulnerabilities
CVE-2026-44933: Path Traversal in Plugin Loading in libzypp
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-20 · updated 2026-07-24
- Weakness: CWE-35
Description
`PluginScript` attempts to `chroot` the plugin to the `repoManagerRoot`, this root is frequently `/` (the system root) in standard configurations or when using `--root`. If the chroot target is `/`, it is a no-op, allowing the traversed path to execute host binaries (like `/bin/bash`) with root privileges.
Affected products
- SUSE openSUSE: from 17.38.8 before 17.38.9 — fixed in 17.38.9
- SUSE Linux Enterprise: from 17.38.8 before 17.38.9 — fixed in 17.38.9
How to fix
Upgrade to a fixed version: SUSE openSUSE 17.38.9; SUSE Linux Enterprise 17.38.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-44933 or the next vulnerability affects your stack