What’s Vulnerable › Vulnerabilities
CVE-2026-44935: Rancher Fleet vulnerable to cross namespace secret disclosure via unvalidated `valuesFrom` references in Helm Deployer
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-02 · updated 2026-10-25
- Weakness: CWE-1287
Description
Missing validation of "valuesFrom" references in Helm Deployer of SUSE Rancher Fleet 0.15 before 0.15.2, 0.14 before 0.14.6, 0.13 before 0.13.11 and 0.12 before 0.12.15 could be used by owners of one tenant to access fleet credentials of other tenants.
Affected products
- SUSE Fleet: from 0.12.0 before 0.12.15; from 0.13.0 before 0.13.11; from 0.14.0 before 0.14.6; from 0.15.0 before 0.15.2 — fixed in 0.12.15, 0.13.11, 0.14.6, 0.15.2
How to fix
Upgrade to a fixed version: SUSE Fleet 0.12.15, 0.13.11, 0.14.6, 0.15.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-44935 or the next vulnerability affects your stack