What’s Vulnerable › Vulnerabilities
CVE-2026-44938: Fleet has PSS Bypass through addLabelsFromOptions in Fleet Agent
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-07 · updated 2026-10-25
- Weakness: CWE-522
Description
A vulnerability has been identified in Fleet's agent-side deployer, which did not filter security-sensitive keys from namespaceLabels in fleet.yaml (or BundleDeployment.spec.options.namespaceLabels) when applying them to the target namespace. An attacker with git push access to a Fleet-monitored repository could overwrite Pod Security Standards (PSS) enforcement labels on a target namespace. This allows the attacker to weaken admission controls and deploy workloads that PSS policies would otherwise block.
Affected products
- SUSE Fleet: from 0.12.0 before 0.12.15; from 0.13.0 before 0.13.11; from 0.14.0 before 0.14.6; from 0.15.0 before 0.15.2 — fixed in 0.12.15, 0.13.11, 0.14.6, 0.15.2
How to fix
Upgrade to a fixed version: SUSE Fleet 0.12.15, 0.13.11, 0.14.6, 0.15.2. Check the vendor advisory for mitigations.
References
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2026-44938
- https://github.com/advisories/GHSA-864g-863m-vcvq
Get alerted when CVE-2026-44938 or the next vulnerability affects your stack