What’s Vulnerable › Vulnerabilities
CVE-2026-4498: Execution with Unnecessary Privileges in Kibana Leading to reading index data beyond their direct Elasticsearch RBAC scope
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-08 · updated 2026-07-25
- Weakness: CWE-250
Description
Execution with Unnecessary Privileges (CWE-250) in Kibana’s Fleet plugin debug route handlers can lead reading index data beyond their direct Elasticsearch RBAC scope via Privilege Abuse (CAPEC-122). This requires an authenticated Kibana user with Fleet sub-feature privileges (such as agents, agent policies, and settings management).
Affected products
- Kibana: from 8.0.0 before 8.19.14; from 9.0.0 before 9.2.8; from 9.3.0 before 9.3.3 — fixed in 8.19.14, 9.2.8, 9.3.3
How to fix
Upgrade to a fixed version: Kibana 8.19.14, 9.2.8, 9.3.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-4498 or the next vulnerability affects your stack