What’s Vulnerable › Vulnerabilities
CVE-2026-44981: CrowdSec LAPI: Denial of Service via Unbounded Gzip Decompression
- Severity: high (CVSS 8.2 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-16 · updated 2026-10-24
- Weakness: CWE-409
Description
CrowdSec offers crowdsourced protection against malicious IPs. From 1.7.0 until 1.7.8, the LAPI router used gin-contrib/gzip with DefaultDecompressHandle globally in pkg/apiserver/controllers/controller.go, causing /v1/watchers and /v1/watchers/login to decompress unauthenticated gzip-compressed JSON request bodies without enforcing a maximum decompressed size and allowing excessive heap allocation that can make LAPI unreachable. This issue is fixed in version 1.7.8.
Affected products
- crowdsecurity crowdsec: from 1.7.0, < 1.7.8
References
- https://github.com/crowdsecurity/crowdsec/commit/54a0dfe6c16b7687b0da6634e0b19ef0f5d9bb30
- https://github.com/crowdsecurity/crowdsec/commit/56d0d6915f7f25941dc5b4f484028646f6601a37
- https://github.com/crowdsecurity/crowdsec/security/advisories/GHSA-273h-gvwr-c3qj
Get alerted when CVE-2026-44981 or the next vulnerability affects your stack