What’s Vulnerable › Vulnerabilities
CVE-2026-44992: OpenClaw 2026.4.5 through 2026.4.19 - MiniMax API Host Override via Workspace dotenv
- Severity: medium (CVSS 5.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-11 · updated 2026-06-17
- Weakness: CWE-441
Description
OpenClaw versions 2026.4.5 before 2026.4.20 contain an environment variable injection vulnerability allowing workspace dotenv to override MINIMAX_API_HOST. Attackers can redirect credentialed MiniMax API requests to attacker-controlled origins, exposing the MiniMax API key in Authorization headers.
Affected products
- OpenClaw: from 2026.4.5 before 2026.4.20 — fixed in 2026.4.20
How to fix
Upgrade to a fixed version: OpenClaw 2026.4.20. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/2f06696579a1ab0cb5bbbbb6a900414a6b2e3cd1
- https://github.com/openclaw/openclaw/security/advisories/GHSA-h2vw-ph2c-jvwf
- https://www.vulncheck.com/advisories/openclaw-minimax-api-host-override-via-workspace-dotenv
Get alerted when CVE-2026-44992 or the next vulnerability affects your stack