What’s Vulnerable › Vulnerabilities
CVE-2026-44994: OpenClaw < 2026.4.22 - Authentication Bypass in Gateway Control UI Bootstrap Config Endpoint
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-11 · updated 2026-06-17
- Weakness: CWE-862
Description
OpenClaw before 2026.4.22 contains an authentication bypass vulnerability in the Control UI bootstrap config endpoint that allows unauthenticated attackers to read sensitive configuration fields. Attackers can access the bootstrap config route without a valid Gateway token to expose sensitive bootstrap and config information intended only for authenticated Control UI sessions.
Affected products
- OpenClaw: before 2026.4.22 — fixed in 2026.4.22
How to fix
Upgrade to a fixed version: OpenClaw 2026.4.22. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/2321d67263bc710e357644d59f746b08d891051b
- https://github.com/openclaw/openclaw/security/advisories/GHSA-93rg-2xm5-2p9v
- https://www.vulncheck.com/advisories/openclaw-authentication-bypass-in-gateway-control-ui-bootstrap-config-endpoint
Get alerted when CVE-2026-44994 or the next vulnerability affects your stack