What’s Vulnerable › Vulnerabilities
CVE-2026-44995: OpenClaw < 2026.4.20 - Arbitrary Code Execution via MCP stdio Environment Variables
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-11 · updated 2026-06-17
- Weakness: CWE-829
Description
OpenClaw before 2026.4.20 contains an improper environment variable validation vulnerability in MCP stdio server configuration that allows attackers to execute arbitrary code. Malicious workspace configurations can pass dangerous startup variables like NODE_OPTIONS, LD_PRELOAD, or BASH_ENV to spawned MCP server processes, enabling code injection when operators start sessions using those servers.
Affected products
- OpenClaw: before 2026.4.20 — fixed in 2026.4.20
How to fix
Upgrade to a fixed version: OpenClaw 2026.4.20. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/62fa5071896e95edc7f67d1cebc70a2859e283af
- https://github.com/openclaw/openclaw/commit/85d86ebc4bf3d2226d39d132a484f4f7a299fa1b
- https://github.com/openclaw/openclaw/security/advisories/GHSA-mj59-h3q9-ghfh
- https://www.vulncheck.com/advisories/openclaw-arbitrary-code-execution-via-mcp-stdio-environment-variables
Get alerted when CVE-2026-44995 or the next vulnerability affects your stack