What’s Vulnerable › Vulnerabilities
CVE-2026-45004: OpenClaw < 2026.4.23 - Arbitrary Code Execution via setup-api.js in Current Working Directory
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-11 · updated 2026-06-17
- Weakness: CWE-427
Description
OpenClaw before 2026.4.23 contains an arbitrary code execution vulnerability in the bundled plugin setup resolver that loads setup-api.js from process.cwd() during provider setup metadata resolution. Attackers can execute arbitrary JavaScript under the current user account by placing a malicious extensions/<plugin>/setup-api.js file in a repository and convincing a user to run OpenClaw commands from that directory.
Affected products
- OpenClaw: before 2026.4.23 — fixed in 2026.4.23
How to fix
Upgrade to a fixed version: OpenClaw 2026.4.23. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/993781e6e6eaf50f033cfc3e3bf4f47059740707
- https://github.com/openclaw/openclaw/security/advisories/GHSA-r39h-4c2p-3jxp
- https://www.vulncheck.com/advisories/openclaw-arbitrary-code-execution-via-setup-api-js-in-current-working-directory
Get alerted when CVE-2026-45004 or the next vulnerability affects your stack