What’s Vulnerable › Vulnerabilities
CVE-2026-45006: OpenClaw < 2026.4.23 - Unsafe Config Mutation via Gateway Tool Denylist Bypass
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-11 · updated 2026-06-17
- Weakness: CWE-184
Description
OpenClaw before 2026.4.23 contains an improper access control vulnerability in the gateway tool's config.apply and config.patch operations that allows compromised models to write unsafe configuration changes by bypassing an incomplete denylist protection. Attackers can persist malicious config modifications affecting command execution, network behavior, credentials, and operator policies that survive restart.
Affected products
- OpenClaw: before 2026.4.23 — fixed in 2026.4.23
How to fix
Upgrade to a fixed version: OpenClaw 2026.4.23. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/bceda6089aa7b3695cc7696b43c61ae3d01bb0ec
- https://github.com/openclaw/openclaw/security/advisories/GHSA-cwj3-vqpp-pmxr
- https://www.vulncheck.com/advisories/openclaw-unsafe-config-mutation-via-gateway-tool-denylist-bypass
Get alerted when CVE-2026-45006 or the next vulnerability affects your stack