What’s Vulnerable › Vulnerabilities
CVE-2026-45031: ImageMagick: Policy Bypass in PSD decoder
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-10 · updated 2026-07-23
- Weakness: CWE-400
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 6.9.13-47 and 7.1.2-22, due to a missing check in the PSD decoder it would be possible to bypass the list-length resource policy when decoding a PSD image. Other security limits would still apply. This issue has been patched in versions 6.9.13-47 and 7.1.2-22.
Affected products
- ImageMagick: before 6.9.13-47; from 7.0.0-0 before 7.1.2-22 — fixed in 6.9.13-47, 7.1.2-22
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-47, 7.1.2-22. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-cwpj-h54c-xjpx
- https://access.redhat.com/errata/RHSA-2026:32961
- https://access.redhat.com/security/cve/CVE-2026-45031
- https://bugzilla.redhat.com/show_bug.cgi?id=2487734
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-45031.json
Get alerted when CVE-2026-45031 or the next vulnerability affects your stack