What’s Vulnerable › Vulnerabilities
CVE-2026-45063: Symfony: Identity Spoofing via Unanchored DN Regex in X509Authenticator
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-14 · updated 2026-07-15
- Weakness: CWE-290
Description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, X509Authenticator extracts the user identifier from $_SERVER['SSL_CLIENT_S_DN'] with an unanchored regex that matches emailAddress= anywhere in the distinguished name, allowing an attacker with a trusted certificate containing emailAddress=victim inside another RDN value such as CN to authenticate as the victim. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.
Affected products
- symfony: before 5.4.52; from 6.0.0 before 6.4.40; from 7.0.0 before 7.4.12; from 8.0.0 before 8.0.12 — fixed in 5.4.52, 6.4.40, 7.4.12, 8.0.12
How to fix
Upgrade to a fixed version: symfony 5.4.52, 6.4.40, 7.4.12, 8.0.12. Check the vendor advisory for mitigations.
References
- https://github.com/symfony/symfony/commit/59ef484029601a7af06f5e06c6ed921fdcea5a0d
- https://github.com/symfony/symfony/releases/tag/v5.4.52
- https://github.com/symfony/symfony/releases/tag/v6.4.40
- https://github.com/symfony/symfony/releases/tag/v7.4.12
- https://github.com/symfony/symfony/releases/tag/v8.0.12
- https://github.com/symfony/symfony/security/advisories/GHSA-ph86-p8f6-f9r2
Get alerted when CVE-2026-45063 or the next vulnerability affects your stack